Skaro Forums Returning

skaro_diamondThe Outpost Skaro Forums, which I know some of you are missing, are now officially back.

We are doing a staged return to try and keep the server load down, so tonight all accounts with greater than 10 posts have been reactivated.  Assuming there’s no hiccups, we’d hope to reactivate the other accounts in the next day or so, and finally re-enable registration after that.

Note that due to the migration of existing accounts, users will need to reset their password before being able to log in.   Also, we’re still constantly tweaking the new setup, so don’t be surprised if there are changes over the next few weeks.

Finally, I know that Tapatalk is popular amongst our users on their mobile devices (I used it too).  Its currently still offline, but we’re looking to get it back soon.  There’ll be an announcement in the forums when its up and running.  In the meantime, the new forums have far better mobile browser support, so hopefully its not too much of an inconvenience.

To access the forums, just use the link in the main menu above.   We’ll update this post once the rest of the accounts are set to live in a day or so.

 

*update* The good news is that the account activations went well, so we’ve completely opened the forum back up now.  All previous accounts will be able to access the forums again, and registration for new users has been enabled.

Updated: July 1, 2014 — 6:14 pm

11 Comments

Add a Comment
  1. We’ll I can’t get in, reset my password, or creat a new Account using email

  2. Hi Kevin,

    Can you please pop a note with details of the email address you’re using and the error/s you get through the contact form on http://www.outpostskaro.com/contact/ please, so we track in the backend and sort for you?

    Thanks!

    Andy

  3. Still can’t get in

  4. The password reset mails isn’t getting caught by your spam filter maybe?

    If it’s getting past and still having issues, please pop a note with username/email and the error/s you’re getting through the contact form at http://www.outpostskaro.com/contact/ so it can be looked into further.

    Thanks!

    Andy

  5. Hi. I can’t get in either. Says it doesn’t recognise my PW. Sent an email 2 days ago. Please let me in……:)

    1. Hi,
      Have you tried the link for a forgotten password to reset it? As a side effect of migrating the accounts all passwords unfortunately need reset.

      If that doesn’t work give us another shout via the contact form with your username and I’ll make sure it gets sorted.

      1. Hi. I have got a new password, which i have put in, and it’s giving me a confirmation code, which when i input it, is taking me back to the log in screen.

        1. Sorry about that Paul. I’ve dropped you an e-mail.

  6. OS does not recognise my user name ‘Alinor’

    1. I’ve checked for you and your username should definitely be working. I’ve dropped you an email.

  7. Thanks, I’m in. Thanks for your help.

Leave a Reply to Elizabeth Boldy Cancel reply

Outpost Skaro © 2014 Frontier Theme